Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C6 Corvette General Discussion
General C6 Corvette Discussion not covered in Tech Sponsored by
PFYC

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 03-12-2010, 09:17 AM   #1
PR4424
CF Member
 
PR4424's Avatar
 
Member Since: Dec 2006
Location: Harrisburg Pa
Default 05 Power top won't close all the way

So last night I drove to my hockey game with the top down and when I got there the top wouldn't close completely. It looked like it was going to close, the top would get about 8" from the windshield but then would go back down (as if I was putting the top down) until it was in the up right position.

I tried shutting the car off several times, indexing the windows and putting the top up and down numerous times. I eventually drove to a GM dealer where service was closed (I was hoping I could find a salesman who knows about verts). Well, I showed him what was happening then he went in to ask his manager for help and when we went back outside to show him it worked.

This happened once before but after trying to open and close it once or twice it closed properly.

Has this ever happened to anybody?
PR4424 is offline   Reply With Quote
Old 03-12-2010, 10:43 AM   #2
Justasheet
CF Senior Member
 
Justasheet's Avatar
 
Member Since: Sep 2008
Location: Palm Beach Fl
Default

Did you get any messages about the partition?
Justasheet is offline   Reply With Quote
Old 03-12-2010, 01:04 PM   #3
PR4424
CF Member
 
PR4424's Avatar
 
Member Since: Dec 2006
Location: Harrisburg Pa
Default

No, there were no messages except saying the top wasn't secure (not closed).

Any ideas?
PR4424 is offline   Reply With Quote
Old 03-12-2010, 01:11 PM   #4
cclive
CF Senior Member
 
cclive's Avatar
 
Member Since: Mar 2008
Location: Southern Utah
Default

I am thinking one of the limit switches...the top doesn't know that it is in that 'almost closed' position.
cclive is online now   Reply With Quote
Old 03-12-2010, 03:38 PM   #5
900590Vettes
CF Senior Member
 
900590Vettes's Avatar
 
Member Since: Jul 2001
Location: Fairview TX
Default

It sounds like the switch you hold in for the top to go up is bad and shorts the other way for down, dunno, maybe...

If it happens at the same position, 8 inches from the windshield, everytime then one of the other switches, but I thought it only activated them switches when it was all the way one direction or the other.

A quick look at the schematic it appears the only way this could happen is a bad control switch or folding top control module. Getting the top not secure message indicates that the control switch was released, that is the only time that it sends that info to the DIC. I bet you have a flakey switch.
900590Vettes is offline   Reply With Quote
Old 03-18-2010, 10:32 AM   #6
PR4424
CF Member
 
PR4424's Avatar
 
Member Since: Dec 2006
Location: Harrisburg Pa
Default

So I have put the top up 5-6 times since the night of the problem and it hasn't happened since then. I am starting to doubt myself thinking that maybe I didn't hold the button long enough. Currently, when I close it it closes 80% of the way then opens slightly, pauses for about 2 -3 seconds then the top comes down the remainder of the way to the windshield.

Is the 2-3 second pause normal? If it is, maybe I was just releasing the button right before it started to move? I can't imagine I was doing that abut I was frustrated so maybe it is possible.
PR4424 is offline   Reply With Quote
Old 03-18-2010, 11:18 AM   #7
IDSRVIT
CF Senior Member
 
IDSRVIT's Avatar
 
Member Since: Jul 2009
Location: Sioux Falls South Dakota
Default

Quote:
Originally Posted by PR4424 View Post
So I have put the top up 5-6 times since the night of the problem and it hasn't happened since then. I am starting to doubt myself thinking that maybe I didn't hold the button long enough. Currently, when I close it it closes 80% of the way then opens slightly, pauses for about 2 -3 seconds then the top comes down the remainder of the way to the windshield.

Is the 2-3 second pause normal? If it is, maybe I was just releasing the button right before it started to move? I can't imagine I was doing that abut I was frustrated so maybe it is possible.
The pause is normal....mine does it too (from what I remember before I stored it last year at least). This last pause I believe is the hard cover latching. Top won't go the rest of the way until that occurs.
IDSRVIT is offline   Reply With Quote
Old 03-23-2010, 07:58 PM   #8
Curti
CF Senior Member
 
Curti's Avatar
 
Member Since: Dec 2009
Default Power top

Did you ever resolve this problem? My car does the same thing, every time. When it gets to the 80% it reverses and starts to lower again.
Maybe it is common to black verts? ( see avatar)
Curti is offline   Reply With Quote
Old 03-23-2010, 08:59 PM   #9
PR4424
CF Member
 
PR4424's Avatar
 
Member Since: Dec 2006
Location: Harrisburg Pa
Default

No, mine does the same thing. Since this is my first Corvette convertible I am assuming this is normal operation. I haven't had a problem closing it since I started this post. I am thinking I was just being too impatient (hopefully).

Am I wrong in thinking that this is normal?
PR4424 is offline   Reply With Quote
Old 03-23-2010, 10:36 PM   #10
cclive
CF Senior Member
 
cclive's Avatar
 
Member Since: Mar 2008
Location: Southern Utah
Default

Quote:
Originally Posted by IDSRVIT View Post
The pause is normal....mine does it too (from what I remember before I stored it last year at least). This last pause I believe is the hard cover latching. Top won't go the rest of the way until that occurs.
cclive is online now   Reply With Quote
Old 03-23-2010, 10:36 PM
 
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Reload this Page 05 Power top won't close all the way
 
 
 
Reply

Tags
2005, c6, control, corvette, folding, module, power, problem, problems, put, secure, switch, top, tops, unlatch


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 09:54 PM.


Emails & Password Backup

Search Engine Friendly URLs by vBSEO 3.5.2