Go Back   Corvette Forum > C5 Corvettes, 1997 - 2004 > C5 Tech
Sign in using an external account
Register Forgot Password?
Register Albums Search Today's Posts Mark Forums Read FAQ
Search
C5 Tech
Corvette Tech/Performance: LS1 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace Sponsored by
Karl Chevrolet

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C6 Parts & Accessories
C5 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 09-15-2013, 08:35 AM   #1
Cmeaux
Junior Member
 
Member Since: Jul 2013
Default Help won't start codes P1518 and P0601

Hi, I am looking for help, I own a 1998 corvette coupe with only 6200 miles, the car has not been used for about 2 years, but I start the car every week or so, last week the battery died so I connected a Schumacher fast charger, and started the car, after 2 minutes the car stopped and I tried to started over but in the display appeared Reduced Engine Power, Service TCS, Service ABS; I pulled the codes and they were P1518 and P0601, I tried deleting them but they appear again, the engine wont start.
I've been reading various threads and doing what some people have done to solve their problems but it hasn't worked.

Here is a list of things I've done to try to start the car:
1 checked all fuses (throtcont)
2 changed the relays between them (when I move one relay there is a noise in the throttle body so I guess it is working)
3 changed the screws on the terminal so they be tight
4 check the volts on the throttle control motor harness
5 checked the front grounds that are next to the headlamps finding no corrosion whatsoever.

I don't know what else to do, hope someone can help me.

Thanks
Cmeaux is offline   Reply With Quote
Old 09-15-2013, 10:01 AM   #2
8VETTE7
CF Senior Member
 
8VETTE7's Avatar
 
Member Since: Jul 2007
Default

Quote:
Originally Posted by Cmeaux View Post
Hi, I am looking for help, I own a 1998 corvette coupe with only 6200 miles, the car has not been used for about 2 years, but I start the car every week or so, last week the battery died so I connected a Schumacher fast charger, and started the car, after 2 minutes the car stopped and I tried to started over but in the display appeared Reduced Engine Power, Service TCS, Service ABS; I pulled the codes and they were P1518 and P0601, I tried deleting them but they appear again, the engine wont start.
I've been reading various threads and doing what some people have done to solve their problems but it hasn't worked.

Here is a list of things I've done to try to start the car:
1 checked all fuses (throtcont)
2 changed the relays between them (when I move one relay there is a noise in the throttle body so I guess it is working)
3 changed the screws on the terminal so they be tight
4 check the volts on the throttle control motor harness
5 checked the front grounds that are next to the headlamps finding no corrosion whatsoever.

I don't know what else to do, hope someone can help me.

Thanks



Won't Start?????

Cranks but will not run??

Doesn't crank???

P0601 - PCM Memory Not a good code to have


P1518 - PCM to TAC module Serial Data Circuit



Are you certain there are no other codes??? P0606 possibly?

This COULD be a TAC module problem. Over the years I have read a number of threads about 98's and these two codes in combination. If the TAC module is not the problem you are looking at replacing the PCM.

Last edited by 8VETTE7; 09-15-2013 at 10:03 AM.
8VETTE7 is offline   Reply With Quote
Old 09-15-2013, 10:46 AM   #3
Cmeaux
Junior Member
 
Member Since: Jul 2013
Default

Thanks for your answer the car will crank but won't start, I checked to see if there is spark but there isn't.
The p1518 and the p0601 are the only two codes for powertrain, it also has codes for ABS and TCS, that are deleted and come back again moments after.
Cmeaux is offline   Reply With Quote
Old 09-16-2013, 12:54 PM   #4
Cmeaux
Junior Member
 
Member Since: Jul 2013
Default

Any idea?
Cmeaux is offline   Reply With Quote
Old 09-16-2013, 06:12 PM   #5
sean.b
CF Senior Member
 
sean.b's Avatar
 
Member Since: Feb 2010
Location: Harvest AL
Default

no spark and those codes is bad PCM, is it not?
sean.b is offline   Reply With Quote
Old 09-16-2013, 06:12 PM
 
Go Back   Corvette Forum > C5 Corvettes, 1997 - 2004 > C5 Tech
Reload this Page Help won't start codes P1518 and P0601
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 10:39 AM.


Emails & Password Backup

Search Engine Friendly URLs by vBSEO 3.5.2