Go Back   Corvette Forum > C5 Corvettes, 1997 - 2004 > C5 Tech
Sign in using an external account
Register Forgot Password?
Register Albums Search Today's Posts Mark Forums Read FAQ
Search
C5 Tech
Corvette Tech/Performance: LS1 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace Sponsored by
Karl Chevrolet

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C6 Parts & Accessories
C5 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 01-09-2010, 07:02 PM   #1
DomZ06
Junior Member
 
Member Since: Jan 2010
Default HUD not showing speed, only RPM

I just bought my 2003 Z06 about a month ago..the Heads up display was working fine, and now the other day the digital speed readout is gone, but the RPM's still show at the top.. Is this a fuse or bulb or does the entire unit have to be replaced??
DomZ06 is offline   Reply With Quote
Old 01-09-2010, 07:12 PM   #2
Blue 92
CF Senior Member
CI 3-4, 8-9-10 Veteran
St. Jude Donor '06-'08-'10
Support Corvetteforum!
 
Blue 92's Avatar
 
Member Since: May 1999
Location: Columbus Ohio
Send a message via AIM to Blue 92
Default

Did you try cycling through the different display options?
Blue 92 is offline   Reply With Quote
Old 01-09-2010, 08:07 PM   #3
DomZ06
Junior Member
 
Member Since: Jan 2010
Default

Quote:
Originally Posted by Blue 92 View Post
Did you try cycling through the different display options?
yea, i press the page button which used to change the other settings and nothing shows up except for the tach at the top/left side
DomZ06 is offline   Reply With Quote
Old 01-09-2010, 08:35 PM   #4
Blue 92
CF Senior Member
CI 3-4, 8-9-10 Veteran
St. Jude Donor '06-'08-'10
Support Corvetteforum!
 
Blue 92's Avatar
 
Member Since: May 1999
Location: Columbus Ohio
Send a message via AIM to Blue 92
Default

Did you try press and hold? Press and release cycles the gauges.

Page 3-18 here:

http://www.gmpartshouse.com/download...03corvette.pdf
Blue 92 is offline   Reply With Quote
Old 01-09-2010, 08:51 PM   #5
DomZ06
Junior Member
 
Member Since: Jan 2010
Default

Quote:
Originally Posted by Blue 92 View Post
Did you try press and hold? Press and release cycles the gauges.

Page 3-18 here:

http://www.gmpartshouse.com/download...03corvette.pdf
Nope, didnt try that but im willing to guess thats what happened lol.. gonna go see if it works in a few mins
DomZ06 is offline   Reply With Quote
Old 01-10-2010, 01:37 AM   #6
DomZ06
Junior Member
 
Member Since: Jan 2010
Default

Thanks man, that was what happened, i must have held the page button for a second too long..it works fine now
DomZ06 is offline   Reply With Quote
Old 01-10-2010, 01:43 AM   #7
Blue 92
CF Senior Member
CI 3-4, 8-9-10 Veteran
St. Jude Donor '06-'08-'10
Support Corvetteforum!
 
Blue 92's Avatar
 
Member Since: May 1999
Location: Columbus Ohio
Send a message via AIM to Blue 92
Default

Quote:
Originally Posted by DomZ06 View Post
Thanks man, that was what happened, i must have held the page button for a second too long..it works fine now
Blue 92 is offline   Reply With Quote
Old 01-10-2010, 09:36 AM   #8
jrose7004
CF Senior Member
 
jrose7004's Avatar
 
Member Since: Mar 2004
Location: Oklahoma City OK
Jim Rose Jim Rhttp://www.linkedin.com/profile/view?id=89789687&trk=hb_tab_pro_topose
Default

Another case closed!
jrose7004 is offline   Reply With Quote
Old 01-10-2010, 11:24 AM   #9
schpenxel
CF Senior Member
 
schpenxel's Avatar
 
Member Since: May 2004
Location: Asheboro NC
Default

lol
schpenxel is offline   Reply With Quote
Old 01-10-2010, 11:24 AM
 
Go Back   Corvette Forum > C5 Corvettes, 1997 - 2004 > C5 Tech
Reload this Page HUD not showing speed, only RPM
 
 
 
Reply

Tags
c6, corvette, hud, reflecting, showing, speed


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
C6 Z06 Frequently Asked Questions(FAQ) LTC Z06 C6 Z06 Discussion 56 08-02-2011 02:23 PM


All times are GMT -4. The time now is 05:38 AM.


Emails & Password Backup

Search Engine Friendly URLs by vBSEO 3.5.2