Go Back   Corvette Forum > C5 Corvettes, 1997 - 2004 > C5 Tech
Sign in using an external account
Register Forgot Password?
Register Albums Search Today's Posts Mark Forums Read FAQ
Search
C5 Tech
Corvette Tech/Performance: LS1 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace Sponsored by
Karl Chevrolet

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C6 Parts & Accessories
C5 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 12-07-2009, 11:50 PM   #1
Tyke
CF Senior Member
 
Member Since: Oct 2007
Default Car turns off when I put in gear (Drive or Reverse)

Hi experts,

Today I was going home from the store and turned on the Vette, put it in reverse (Auto Tranny) and the car turned off immediately.
It started right back up, put it in drive and again, turned off immeditely.
Did this for about 10 times and kept doing the same thing.
If I kept the car off gear I could rev the hell out of it and no problem, but as soon as I put it in gear it turned off.
So I was ready for tow truck so I called my wife to pick me up. When she got there I attemted to move the car 1 more time and it worked fine, so I drove it home. Now Im worried, I dont want to get stranded.
ANY ideas? I dont know whats going on!
Tyke is offline   Reply With Quote
Old 12-07-2009, 11:56 PM   #2
lucky131969
Tech Contributor

 
lucky131969's Avatar
 
Member Since: Jan 2007
Location: Hoffman Estates IL
Send a message via Yahoo to lucky131969
Default

Quote:
Originally Posted by Tyke View Post
Hi experts,

Today I was going home from the store and turned on the Vette, put it in reverse (Auto Tranny) and the car turned off immediately.
It started right back up, put it in drive and again, turned off immeditely.
Did this for about 10 times and kept doing the same thing.
If I kept the car off gear I could rev the hell out of it and no problem, but as soon as I put it in gear it turned off.
So I was ready for tow truck so I called my wife to pick me up. When she got there I attemted to move the car 1 more time and it worked fine, so I drove it home. Now Im worried, I dont want to get stranded.
ANY ideas? I dont know whats going on!
Did she use a different key?
lucky131969 is offline   Reply With Quote
Old 12-08-2009, 12:20 AM   #3
Tyke
CF Senior Member
 
Member Since: Oct 2007
Default

No the same key. Why you think it could be the security sensor? If so why would it allow me to start it?
Tyke is offline   Reply With Quote
Old 12-08-2009, 12:28 AM   #4
Millenium Z06
CF Senior Member

 
Millenium Z06's Avatar
 
Member Since: Jun 2004
Location: Frisco Texas
Default

Sounds like a vats (security) system problem; I assume thats what an auto does when the system is engaged. On a manual, it will go to 1mph then shut off I guess an auto just needs to be put in gear.
Millenium Z06 is offline   Reply With Quote
Old 12-08-2009, 12:35 AM   #5
lucky131969
Tech Contributor

 
lucky131969's Avatar
 
Member Since: Jan 2007
Location: Hoffman Estates IL
Send a message via Yahoo to lucky131969
Default

Quote:
Originally Posted by Tyke View Post
No the same key. Why you think it could be the security sensor? If so why would it allow me to start it?
Pull your codes and post..
lucky131969 is offline   Reply With Quote
Old 12-08-2009, 12:51 AM   #6
luv my vettes
Junior Member
 
Member Since: Dec 2009
Default

Did you have the key in the ignition for a while before you turned it on??
luv my vettes is offline   Reply With Quote
Old 12-08-2009, 12:52 AM   #7
Tyke
CF Senior Member
 
Member Since: Oct 2007
Default

HEre are my codes:

B2587 Column Lock/Unlock Drive (A) H

B2592 Column Lock/Unlock Drive (B) H

B2721 PASS-Key Detection Circuit H

B2723 PASS-Key Detection Circuit H C

U1160 Loss of Communications with LDCM H

B2284 Battery #2 Fault H

B2285 Battery #2 Fault H

U1096 Loss of Communication with IPC H

U1064 Loss of Communication with BCM H

U1016 Loss of Communication with PCM H


Tyke is offline   Reply With Quote
Old 12-08-2009, 12:53 AM   #8
Tyke
CF Senior Member
 
Member Since: Oct 2007
Default

Quote:
Originally Posted by luv my vettes View Post
Did you have the key in the ignition for a while before you turned it on??
No, I did what I ussually do, stick key in start and go
Tyke is offline   Reply With Quote
Old 12-08-2009, 08:55 AM   #9
lucky131969
Tech Contributor

 
lucky131969's Avatar
 
Member Since: Jan 2007
Location: Hoffman Estates IL
Send a message via Yahoo to lucky131969
Default

Quote:
Originally Posted by Tyke View Post
HEre are my codes:

B2587 Column Lock/Unlock Drive (A) H

B2592 Column Lock/Unlock Drive (B) H

B2721 PASS-Key Detection Circuit H

B2723 PASS-Key Detection Circuit H C

U1160 Loss of Communications with LDCM H

B2284 Battery #2 Fault H

B2285 Battery #2 Fault H

U1096 Loss of Communication with IPC H

U1064 Loss of Communication with BCM H

U1016 Loss of Communication with PCM H


Based on the communication, battery, and pass key codes, it sounds like you are ready for a new ignition switch assembly.
lucky131969 is offline   Reply With Quote
Old 12-08-2009, 09:14 AM   #10
BLOWNBLUEZ06
Tech Contributor

 
BLOWNBLUEZ06's Avatar
 
Member Since: Apr 2007
Location: Forney Texas
Default

Quote:
Originally Posted by lucky131969 View Post
Based on the communication, battery, and pass key codes, it sounds like you are ready for a new ignition switch assembly.
Or maybe a Bill Curlee tutorial read on the rebuild if you're a reasonably mechanically inclined individual?
BLOWNBLUEZ06 is offline   Reply With Quote
Old 12-08-2009, 09:41 AM   #11
8VETTE7
CF Senior Member
 
8VETTE7's Avatar
 
Member Since: Jul 2007
Default

Certainly sounds as though the ignition switch may be at fault but might it also be the bare wire in the accordian boot problem that intermitantly shorts out the serial data buss resulting in the loss of communications?

Check out this link:

http://forums.corvetteforum.com/c5-t...n-long-32.html

Than go to post #640.
8VETTE7 is offline   Reply With Quote
Old 12-08-2009, 03:07 PM   #12
Tyke
CF Senior Member
 
Member Since: Oct 2007
Default

Quote:
Originally Posted by BLOWNBLUEZ06 View Post
Or maybe a Bill Curlee tutorial read on the rebuild if you're a reasonably mechanically inclined individual?
I just did the Ignition repair thing from Bill Curlee...going to see if problem continues after this.
Tyke is offline   Reply With Quote
Old 12-08-2009, 03:07 PM
 
Go Back   Corvette Forum > C5 Corvettes, 1997 - 2004 > C5 Tech
Reload this Page Car turns off when I put in gear (Drive or Reverse)
 
 
 
Reply

Tags
2000, c5, car, corvette, drive, gear, off, problem, put, reverse, security, shuts, truck, turns, z06


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weights, measurements, ratios, strengths, etc leaftye C5 Tech 252 02-02-2014 12:23 PM
NEW TO AUTO-X AND ROADRACING? look in here... Jack Bauer Autocrossing & Roadracing 216 12-30-2013 05:10 PM
4,743 miles in a Sting Ray roadster (long) LouieM C1 & C2 Corvettes 53 06-14-2004 03:07 PM
Corsa install, DIY or pay my independent? froggy47 C4 Tech/Performance 9 11-03-2003 04:08 PM
Thanks Andy, I get rubber in all four gears! Alot of it! BADBLACK99 C5 Forced Induction/Nitrous 12 08-27-2003 01:13 AM
I had a torque tube failure Gary2KC5 Autocrossing & Roadracing 21 06-22-2003 07:53 PM
Why does my car hate reverse. Help please, any ideas welcome. Nathan Plemons C4 Tech/Performance 9 12-19-2001 11:22 AM


All times are GMT -4. The time now is 03:30 PM.


Emails & Password Backup

Search Engine Friendly URLs by vBSEO 3.5.2