Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Albums Search Today's Posts Mark Forums Read FAQ
Search
C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine Sponsored by
J&D Corvette

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C6 Parts & Accessories
C5 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 08-05-2010, 01:46 PM   #1
jakers
CF Senior Member
St. Jude Donor '06
 
jakers's Avatar
 
Member Since: Feb 2005
Location: Midland Georgia
Default Cruise Control Indicator Light

I recently replaced the vacuum hose that leads from under the dash through the firewall and on to the CC solenoid. Up unitl last night, I have not had a chance to test the fix. I took the car out for a little sunset cruise with the wife. After some nice country roads we came to a stretch of 4 lane road. Just for kicks and not expecting any results, I pushed the button to set my cruise. HOLY SMOKE, the dang CC engaged! I now have cruise control!!! I was so tickled that I laughed out loud...

Need to solve one problem, I do not have the Cruise Control Indicator light illuminating in the instrument display when the cruise is engaged. Bulb out perhaps. Has anyone else had this issue? Beyond the light bulb in the dash what else should I check? Anyone have/had a similar issue?

Last edited by jakers; 08-05-2010 at 01:49 PM.
jakers is offline   Reply With Quote
Old 08-06-2010, 12:12 PM   #2
onedef92
CF Senior Member
Cruise-In IV Veteran
Cruise-In VI Veteran
Cruise-In VII Veteran
Cruise-In VIII Veteran
 
onedef92's Avatar
 
Member Since: Oct 2000
Location: Louisville KY
Default

What year Vette? I have a '92 and wasn't aware there was a CC light on the dash.
onedef92 is offline   Reply With Quote
Old 08-06-2010, 12:44 PM   #3
engle1147
CF Senior Member
Support Corvetteforum!

 
engle1147's Avatar
 
Member Since: Jul 2007
Location: Tampa Florida
Send a message via AIM to engle1147
Default

Quote:
Originally Posted by onedef92 View Post
What year Vette? I have a '92 and wasn't aware there was a CC light on the dash.
OP's profile indicates a '94.
No CC indicator.

Click the image to open in full size.

Glad to hear you've got your cruise control back in order.
engle1147 is offline   Reply With Quote
Old 08-06-2010, 01:28 PM   #4
aminnich
CF Senior Member

 
aminnich's Avatar
 
Member Since: Jan 2006
Location: Woodstock Georgia
Default

Quote:
Originally Posted by jakers View Post
I recently replaced the vacuum hose that leads from under the dash through the firewall and on to the CC solenoid. Up unitl last night, I have not had a chance to test the fix. I took the car out for a little sunset cruise with the wife. After some nice country roads we came to a stretch of 4 lane road. Just for kicks and not expecting any results, I pushed the button to set my cruise. HOLY SMOKE, the dang CC engaged! I now have cruise control!!! I was so tickled that I laughed out loud...

Need to solve one problem, I do not have the Cruise Control Indicator light illuminating in the instrument display when the cruise is engaged. Bulb out perhaps. Has anyone else had this issue? Beyond the light bulb in the dash what else should I check? Anyone have/had a similar issue?
Cool, one more thing to check off the to do list. There is no cruise indicator light on my 95, doubt there should be one on yours either.
aminnich is offline   Reply With Quote
Old 08-06-2010, 09:28 PM   #5
RollaMo-LT4
CF Senior Member
St. Jude Donor '10-'11-'12-'13
 
RollaMo-LT4's Avatar
 
Member Since: Oct 2005
Location: Rolla Missouri
Default

I don't think any C4 has a cruise indicator light.
I can verify no indicator light on the '96.
__________________
1996 Corvette - LT4
2011 Camaro SS Convertible
2011 Harley Davidson FLHX Street Glide
RollaMo-LT4 is offline   Reply With Quote
Old 08-07-2010, 10:56 PM   #6
jakers
CF Senior Member
St. Jude Donor '06
 
jakers's Avatar
 
Member Since: Feb 2005
Location: Midland Georgia
Default duh!

Quote:
Originally Posted by aminnich View Post
Cool, one more thing to check off the to do list. There is no cruise indicator light on my 95, doubt there should be one on yours either.

Thanks Folks!



& a BIG DUH! I have had GM trucks for years and made the assumption, before I checking the FSM or the owner's manual, that there would be one on the Vette. The good news is that now I don't have to worry about pulling the dash out to fix it! One less thing to do!!!!
jakers is offline   Reply With Quote
Old 08-08-2010, 09:40 PM   #7
HlhnEast
CF Senior Member
 
HlhnEast's Avatar
 
Member Since: Nov 2008
Location: Jacksonville FL
Default

I wondered about this with my '85 as nothing lights up when engaged. Figured there would be something.
HlhnEast is offline   Reply With Quote
Old 08-08-2010, 10:51 PM   #8
Pwnage1337
Tech Contributor

 
Pwnage1337's Avatar
 
Member Since: Oct 2008
Location: Amherst Junction Wi
Send a message via MSN to Pwnage1337
Default

Kinda surprising that there isn't a CC light. I suppose they were probably more worried about the important things when they designed the cluster
Pwnage1337 is offline   Reply With Quote
Old 08-09-2010, 09:05 AM   #9
Sinistrad
CF Senior Member

 
Sinistrad's Avatar
 
Member Since: May 2006
Location: Greenbrier AR
Default

Quote:
Originally Posted by Pwnage1337 View Post
Kinda surprising that there isn't a CC light. I suppose they were probably more worried about the important things when they designed the cluster
Maybe they figured most people don't need a light to remind them that they've pressed a button and their foot's off the pedal.

What concerned me more than the missing light on my '92 auto, was that there's no cancel when I flick the transmission to neutral.
Sinistrad is offline   Reply With Quote
Old 08-09-2010, 09:16 AM   #10
Black92FX36spd
CF Senior Member

 
Black92FX36spd's Avatar
 
Member Since: Jul 2010
Location: Siloam Springs AR
Default

Well my CC doesn't work either and I couldn't get my "light" to come on either. Thanks that is one less problem to solve, now to replace the Vac hose to see if that fixes it. ":cross fingers:"
Black92FX36spd is offline   Reply With Quote
Old 08-09-2010, 04:47 PM   #11
JAKE
CF Senior Member
 
JAKE's Avatar
 
Member Since: Feb 2000
Location: Kempner Texas
Default

Quote:
Originally Posted by Sinistrad View Post
Maybe they figured most people don't need a light to remind them that they've pressed a button and their foot's off the pedal.

What concerned me more than the missing light on my '92 auto, was that there's no cancel when I flick the transmission to neutral.
Apparently it wasn't designed for the trans in neutral to do that. Yet once the engine hits redline with the trans in neutral I'll bet the cruise will shut down.

Jake
JAKE is offline   Reply With Quote
Old 08-09-2010, 04:47 PM
 
Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page Cruise Control Indicator Light
 
 
 
Reply

Tags
1989, 1995, 2000, 85, c6, chevy, control, corvette, cruise, indicator, light


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 05:24 AM.


Emails & Password Backup

Search Engine Friendly URLs by vBSEO 3.5.2