Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine Sponsored by
J&D Corvette

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 08-23-2006, 07:41 PM   #1
BCvette
Junior Member
 
BCvette's Avatar
 
Member Since: Jun 2003
Location: Vancouver BC
Default BCM for 93 LT1

A remanufactured body control module (bcm) in my 93 just failed. After a few minutes of driving I'm getting the service ASR light on the center control panel, sys is flashing on the speedo display and the security light is flashing. Apparently GM was having difficulty with the company doing the reman's. GM has dropped availability for this part (GM 16193458). The problems above are annoying but what is critical is when the bcm is in the communications failure mode described above and you shut the car off, then try to restart it the computers think you are trying to steal the car and the car shuts off. You have to wait for it to cool before it will restart.

Does anyone know of a company that will service the bcm? I've contacted Auto Computer Exchange (FL) and Engine Control Units Direct (FL) and neither of them will service the part. I emailed Mid America, suggested by Thomas Barr (NCRS) and they haven't got back to me in over a week so the answer there is likely no.
BCvette is offline   Reply With Quote
Old 08-24-2006, 07:35 AM   #2
Tom Piper
CF Senior Member
 
Tom Piper's Avatar
 
Member Since: Feb 1999
Location: Mexico Beach FL
Default

Sounds like an ECM, not CCM, problem to me.

http://forums.corvetteforum.com/show....php?t=1479977

Tom Piper
Tom Piper is offline   Reply With Quote
Old 08-24-2006, 11:39 AM   #3
BCvette
Junior Member
 
BCvette's Avatar
 
Member Since: Jun 2003
Location: Vancouver BC
Default

Local Corvette expert checked all electrical connectors. He then consulted with Gordon Killebrew of C4 fame and they concluded it was the bcm not a bad connection and not the ecm. I have seen some people claim some success by wacking the ecm when it is in communications failure mode. I've yet to try that but I will.
BCvette is offline   Reply With Quote
Old 09-15-2006, 07:29 PM   #4
zr1_actuary
Junior Member
 
Member Since: Jul 2006
Default

It's my understanding that GM will no longer be producing this particular bcm (part # 88999216) effective 8-24-06, and now the only way to get one from them is to send it in for remanufacture. The local dealer tells me, though, that GM has a notoriously high "loss" rate and there is a chance that you may not ever get yours back. It took me almost 3 months to track down a bcm for my 92 (same p/n) and it was through a guy on the zr-1 net registry... if you're having trouble tracking one of these down, let me know and I can get you in touch with him to see if he has any others.
zr1_actuary is offline   Reply With Quote
Old 09-15-2006, 07:55 PM   #5
bogus
CF Senior Member
 
Member Since: Aug 2000
Location: San Pedro CA
Send a message via Yahoo to bogus
Default

I think I need to get meself a backup CCM...
bogus is offline   Reply With Quote
Old 09-15-2006, 08:00 PM   #6
Carpenter
CF Senior Member
 
Carpenter's Avatar
 
Member Since: Feb 2006
Location: Vancouver B.C.
Default

thinkin' the same...
Carpenter is offline   Reply With Quote
Old 09-15-2006, 08:00 PM
 
Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page BCM for 93 LT1
 
 
 
Reply

Tags
16193458, 88999216, 93, bad, bcm, body, c4, camaro, control, corvette, gm, lt1, module, pictures, reman, testing, vette


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 07:51 AM.


Emails & Password Backup

Search Engine Friendly URLs by vBSEO 3.5.2