Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 General Discussion
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C4 General Discussion
General C4 Corvette Discussion not covered in Tech

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 09-14-2008, 06:52 PM   #1
rvs
Junior Member
 
Member Since: Sep 2005
Location: Lincoln Ne
Default Climate Control Problems

I have a 93 convert. that the climate control system will not adjust temp. colder after initial startup, it will increase temp. If I turnoff engine and restart the temp can be adjusted colder. Any ideas out there? Thanks for your help.
rvs is offline   Reply With Quote
Old 09-15-2008, 11:56 PM   #2
Jonathon1990vette
CF Senior Member
 
Member Since: Feb 2008
Location: South, South Texas Texas
Default

Mine has been messing up also. iI can't adjust the air flow higher and lower. Sometimes radom it will actually let me adjust it but most of the time not. And that module thing is like two hundred something at ecklers.. So i would like to hear idea's also.
Jonathon1990vette is offline   Reply With Quote
Old 09-16-2008, 12:15 AM   #3
2005 coupe
CF Senior Member
 
2005 coupe's Avatar
 
Member Since: Jun 2000
Location: Sedona AZ
Default Climate Control Problems

Take it out, clean all the contacts, put it back in. Will probially run great again, at least mine did. another thing you can try, pull the fuse, run the car for over 5 miles. Shut it off, put the fuse back in and drive more then 5 miles.

Last edited by 2005 coupe; 09-16-2008 at 12:17 AM. Reason: added more info
2005 coupe is offline   Reply With Quote
Old 09-16-2008, 03:04 AM   #4
VinceC4
CF Senior Member
 
VinceC4's Avatar
 
Member Since: Jul 2005
Location: Fuquay Varina North Carolina
Default

I had almost the same problem, When I tried to adjust the climate control nothing would happen. It seemed to happen if I let the car sit for a week or so, or when it rained..I cleaned all the contacts and it has been perfect ever since.
VinceC4 is offline   Reply With Quote
Old 09-16-2008, 07:48 AM   #5
Soon2Bcammed
CF Senior Member
 
Member Since: Aug 2007
Location: Auburn MA
Send a message via AIM to Soon2Bcammed
Default

I also had the same problem, one day it was about 95* outside and i went to put the A/C on.. the heat turned on and everytime i hit the temp "lower" button.. the temp would get higher!!

I took it apart and cleaned the contacts with a few q-tips and rubbing alcohol. It has worked perfect ever since.
__________________

1987 Camaro Z28- 335ci TPI stroker, Tremec TKO 500 trans, 3.42 10 bolt
1994 Corvette - 355ci LT1, LT4 Hot Cam, Bolt ons, Z07 suspension (1 of 887 that year)
Soon2Bcammed is offline   Reply With Quote
Old 12-27-2010, 11:31 PM   #6
jgiuffre
Junior Member
 
Member Since: Dec 2010
Default AC control module

Where is the AC control module located? I would like to try cleaning the contacts. My temperature won't change up or down.

John
jgiuffre is offline   Reply With Quote
Old 12-28-2010, 01:03 AM   #7
larry93lt1
CF Senior Member
 
larry93lt1's Avatar
 
Member Since: May 2010
Location: Gaithersburg MD A member since 2007 but then the computer crashed and then the car crash loss of memory X 2
Default

I wish I had that problem. The '92 I got in August had a heater core leak the night I bought it on the way home. I put a bypass in until October, replaced the heater core, it was as much as a PIA as the '93 I sold the day before I got the '92 except a broken ground wire added to the excitement of the '92's.

My heat will work only if I set the heat at 85 or 90 anything below that and it's cold air. Not real enjoyable when it's 26 outside.
larry93lt1 is offline   Reply With Quote
Old 12-28-2010, 01:03 AM
 
Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 General Discussion
Reload this Page Climate Control Problems
 
 
 
Reply

Tags
1987, 2000, 87, 94, ac, c5, climate, control, corvette, issues, part, problem, problems, sale, vette


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 06:58 PM.


Emails & Password Backup

Search Engine Friendly URLs by vBSEO 3.5.2