Go Back   Corvette Forum > C3 Corvettes, 1968 - 1982 > C3 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Albums Search Today's Posts Mark Forums Read FAQ
Search
C3 Tech/Performance
V8 Technical Info, Internal Engine, External Engine, Basic Tech and Maintenance for the C3 Corvette Sponsored by
VBP

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C6 Parts & Accessories
C5 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 08-14-2006, 11:07 AM   #1
75BrownC3
CF Senior Member
 
75BrownC3's Avatar
 
Member Since: Jul 2006
Location: Rhineland MO
Default Battery Keeps Going Dead

This past Friday I took out the Vette to a local cruise. I brought it home and parked it in the garage. Saturday I thought I would try to find out why my radio wasn't working so I took the passenger side dash apart to get to the speakers. Found out that the speaker is no good anymore but the radio does work. I kept it apart after I removed the speaker. Sunday I go out and the battery is dead. I did close all the doors Saturday so the interior light was not on. I put a charger on the battery all day long and it still won't start or even turn over. I did have an interior light yesterday but went out this morning and nothing. Is there anything behind the passenger dash that may be triggered when it is removed?
75BrownC3 is offline   Reply With Quote
Old 08-14-2006, 02:24 PM   #2
ljthe2nd
CF Senior Member
 
ljthe2nd's Avatar
 
Member Since: Mar 2005
Location: North Port Fl
Default

Are you sure the battery is any good?
__________________
Larry
ljthe2nd is offline   Reply With Quote
Old 08-14-2006, 02:32 PM   #3
MartyW
CF Senior Member
Support Corvetteforum!
 
MartyW's Avatar
 
Member Since: Nov 2005
Location: Breckenridge Colorado
Send a message via AIM to MartyW
Default

Quote:
Originally Posted by ljthe2nd
Are you sure the battery is any good?

After charging it did you check with a voltmeter? It should read 12.6 I believe if fully charged.
MartyW is offline   Reply With Quote
Old 08-14-2006, 02:38 PM   #4
75BrownC3
CF Senior Member
 
75BrownC3's Avatar
 
Member Since: Jul 2006
Location: Rhineland MO
Default

The battery is less than 6 months old but that don't mean squat. I'll have to borrow my friends volt meter to check it out. When I get home tonight, I'll put the dash back together and put the charger back on it.
75BrownC3 is offline   Reply With Quote
Old 08-14-2006, 02:44 PM   #5
craigbaker
Junior Member
 
Member Since: May 2006
Default

I had the same with my 75 this weekend Left the car for a few days without starting and then it won't turn over. I'd check that the battery holds a charge first - charge it up and then see if you can turn the lights or wipers on after leaving it for a while. If it still doesn't hold a charge you'll almost certainly need a new battery. If it does, and the car won't turn over it's probably an alternator/solenoid/starter motor/wiring problem.

anyways, hope you get it sorted!

Craig
craigbaker is offline   Reply With Quote
Old 08-14-2006, 08:20 PM   #6
75BrownC3
CF Senior Member
 
75BrownC3's Avatar
 
Member Since: Jul 2006
Location: Rhineland MO
Default

I think I may have found my problem. There is a box behind the passenger side dash with about 8 wires going to it in a wiring harness. I am thinking there might be a short either in the connector or in the box that the wiring harness plugs into. I don't know what this box is or what it does. I can't find where it is supposed to be mounted to either. Any help knowing what this box is or what it does?
75BrownC3 is offline   Reply With Quote
Old 08-14-2006, 08:20 PM
 
Go Back   Corvette Forum > C3 Corvettes, 1968 - 1982 > C3 Tech/Performance
Reload this Page Battery Keeps Going Dead
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
93 Battery keeps going dead 93rubyredvette C4 Tech/Performance 13 05-12-2005 08:35 PM
Dead Battery vonreichenbach C5 General 11 02-06-2005 05:08 PM
Where to get a battery tender? EuG C5 Tech 16 11-30-2002 08:30 AM
Battery keeps discharging? C5Rated C5 Tech 13 07-25-2002 02:49 PM


All times are GMT -4. The time now is 07:22 PM.


Emails & Password Backup

Search Engine Friendly URLs by vBSEO 3.5.2